Technik: USB Tipp

Erinnert sich noch jemand an parallele Schnittstellen, RS232 und IEEE 1394? Die USB-Schnittstelle brachte enorme Vorteile mit sich. Doch wie ich kürzlich feststellen musste: Der Teufel steckt im Detail. An einem neuen Computer funktionierte die TIS-Kamera unerwartet nicht mehr zuverlässig. Das Problem konnte zum Glück erstaunlich leicht gelöst werden.

Immerhin acht Jahre hat der alte Laptop treue Dienste geleistet. Er funktioniert auch immer noch, allerdings will ich ihn nicht mehr als Hauptrechner ins Internet lassen. Sein Betriebssystem ist noch Windows 7.

Neue Laptops zeichnen sich nicht nur durch andere Festplatten und Software aus. Auch die Schnittstellen haben sich geändert. Der alte Laptop und die TIS-Kamera hatten noch USB 2.0-Anschlüsse. Der neue Laptop hat nun USB 3.0-Anschlüsse.

Nun sollte die Kamera eigentlich kompatibel sein und ihr 2.0 am neuen 3.0 auch funktionieren. Auch Treiber und Software gab es für Windows 10.

Also alles installiert, angeschlossen, und los ging es. Ja, da kam auch das erste Bild. Perfekt!

Das Problem

Dann meldete die Software auf einmal „Das Gerät … befindet sich im Live-Modus, liefert aber keine Bilder“ (The device is in live mode, but does not deliver images“, siehe Fehlermeldung:

Ein genauer Blick auf die USB-Ports zeigte: Einer von beiden ist mit Stromversorgungssymbol, das andere ohne. Okay, also umgesteckt auf den Port mit Symbol und wieder versucht. Aha, da ist das Bild.

Und dann versuchte ich, ein Sternenspektrum aufzunehmen.

Bei einer Belichtungszeit von einer Sekunde erwartete ich, 30 Bilder in etwas mehr als 30 Sekunden im Kasten zu haben. So war es zumindest mit dem alten Laptop. Doch weit gefehlt: Es dauerte eher 3 Minuten! Die Bilder kamen sehr unregelmäßig: Manchmal kamen drei Bilder im Sekundentakt, dann kam eine lange Pause.

Irgendwas lag noch im Argen.

Die Lösung

Den besten Hinweis brachte ein Gespräch mit dem IT-Mitarbeiter bei meinem Arbeitgeber. USB 2.0 an 3.0 und Stromversorgung, da kann es Probleme geben, sagte er. Und er empfahl eine einfache Lösung: Einen USB 2.0-Hub dazwischenschalten.

Wichtig: Dieser muss eine eigene Stromversorgung haben, also an ein (Stecker-)Netzteil angeschlossen sein. Dies ist im Titelbild dieser Beitrags gezeigt.

Zwischen Laptop 1 und der Kamera 2 mit dem Objektiv 3 ist der USB-Hub 4 geschaltet. Ein Steckernetzteil 5 versorgt den USB-Hub 4 mit Strom.

Und damit funktioniert die Kamera nun wieder zuverlässig.

Dieser Beitrag wurde unter Technik veröffentlicht. Setze ein Lesezeichen auf den Permalink.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.